Hi All, has anyone been able to get cert-manager i...
# general
Hi All, has anyone been able to get cert-manager installed in their k8s cluster via pulumi (https://www.pulumi.com/registry/packages/kubernetes-cert-manager/). I know just installing the helm chart doesnt work so i tried to use the pulumi resource, but on my mac it complains that it needs v0.0.3 and is on v0.0.1. My tsConfig is showing the v0.0.3 dependency and i just tried to manually update all dependencies as well but it is still failing. Is there a away around this that doesnt require manual action so my deployments can continue to be automated?
it actually creates the resources, but fails on the initial run and then succeeds if i re-run pulumi up right away
I'm a Pulumi newby so sorry I can't help. This kind of error in Terraform can usually be solved by adding a
block so the resource isn't created until the resources it needs are finished creating. I don't know how this is done in Pulumi. I have found the chat on their website a way to get technical assistance if no one here is able to.