Thread
#general
    h

    helpful-account-44059

    5 months ago
    Hi, i found the pulumi will update the monitoringInterval everytime even i don't change anything, is it normal? it took a long time
    export const rds = new aws.rds.Instance(baseTags.Name, {
        tags: baseTags,
        engine: "postgres",
        engineVersion: "13.6",
        allocatedStorage: 500,
        maxAllocatedStorage: 2000,
        instanceClass: "db.m5.xlarge",
        backupRetentionPeriod: 7,
        backupWindow: "00:00-01:00",
        maintenanceWindow: "Mon:02:00-Mon:04:00",
        monitoringRoleArn: enhancedMonitoringRole.arn,
        monitoringInterval: 15,
        username: "postgres",
        password: baseConfig.dbPassword,
        dbName: baseConfig.dbName,
        finalSnapshotIdentifier,
        storageType: "gp2",
        skipFinalSnapshot: false,
        dbSubnetGroupName: subnetGroup.name,
        vpcSecurityGroupIds: [networkingStack.getOutput("peeredSecurityGroupId")],
    });
    v

    victorious-church-57397

    5 months ago
    if this is happening every time, whilst i investigated I’d probably try setting
    ignoreChanges: ['monitoringInterval']
    in the pulumi component resource opts
    h

    helpful-account-44059

    5 months ago
    like this ?
    v

    victorious-church-57397

    5 months ago
    yep, looks good to me!
    its not an ideal solution, but will help speed things up for you when you’re investigating whats going on
    a

    acoustic-truck-53557

    5 months ago
    I might be wrong. But this is probably a parameter that is scheduled to be changed in the next maintenance window. So until it doesn´t happen, pulumi will always point this is an item to update. If this is the case, you can use
    apply_immediately