https://pulumi.com logo
Title
a

alert-zebra-27114

04/06/2022, 10:09 AM
I would like to move to aws-classic 5.1 as it solves some essential problems around ElasticCache... but as I also use EKS, I cannot do that because the current EKS is not compatible with 5.1, but only <5.0. Two questions: • What is the ETA for EKS (compatible with AWS 5.1)? • Any other solutions to these dependencies issues? I expect this to be become even worse in the future, if we also use the API Gateway plugin!
b

bored-oyster-3147

04/06/2022, 12:26 PM
I'm unsure of the specifics of your problem, but just an FYI that there are no inherent issues with using both providers if doing so would solve your problem in the meantime
💯 2
a

alert-zebra-27114

04/07/2022, 9:13 AM
I get a dependency message... - see https://github.com/pulumi/pulumi-eks/issues/674
b

bored-oyster-3147

04/07/2022, 2:31 PM
Ah, OK. I misunderstood and spoke too quickly. Sorry about that. It looks like pulumi needs to do a new release of
pulumi-eks
Are you able to use the AWS Native provider to solve your elastic cache issues, so that you can keep your AWS Classic provider <5.0 for now? I suspect the reason why
pulumi-eks
hasn't released is because they are focusing on aws-native and I would expect them to have plans to migrate pulumi-eks to use aws-native instead of classic
It's obviously in public preview still so if you don't want to use aws-native yet for that reason I would understand, but just a thought.
a

alert-zebra-27114

04/08/2022, 5:59 AM
I have not tried AWS-native yet in a bigger scale... I guess the two editions (classic and native) should work fine together as they really interchange various AWS IDs.
b

bored-oyster-3147

04/08/2022, 2:15 PM
yes you should be able to use aws-native and aws-classic alongside eachother without issues
and given that aws-native is generated from Cloud Control APIs I would expect it to have the up-to-date APIs for the elasticcache resources
👍 1