https://pulumi.com logo
#general
Title
# general
m

many-psychiatrist-74327

03/31/2022, 4:00 PM
👋 Hi all, I’m trying to create a simple
gcp.container.NodePool
, but
pulumi up
keeps failing with a 404:
Copy code
gcp:container:NodePool (dev-gcp-us-east1-pool2):
    error: 1 error occurred:
    	* creating urn:pulumi:dev::infra::gcp:container/nodePool:NodePool::dev-gcp-us-east1-pool2: 1 error occurred:
    	* error creating NodePool: googleapi: got HTTP response code 404 with body: <!DOCTYPE html>
    <html lang=en>
      <meta charset=utf-8>
      <meta name=viewport content="initial-scale=1, minimum-scale=1, width=device-width">
      <title>Error 404 (Not Found)!!1</title>
      <style>
        *{margin:0;padding:0}html,code{font:15px/22px arial,sans-serif}html{background:#fff;color:#222;padding:15px}body{margin:7% auto 0;max-width:390px;min-height:180px;padding:30px 0 15px}* > body{background:url(//www.google.com/images/errors/robot.png) 100% 5px no-repeat;padding-right:205px}p{margin:11px 0 22px;overflow:hidden}ins{color:#777;text-decoration:none}a img{border:0}@media screen and (max-width:772px){body{background:none;margin-top:0;max-width:none;padding-right:0}}#logo{background:url(//www.google.com/images/branding/googlelogo/1x/googlelogo_color_150x54dp.png) no-repeat;margin-left:-5px}@media only screen and (min-resolution:192dpi){#logo{background:url(//www.google.com/images/branding/googlelogo/2x/googlelogo_color_150x54dp.png) no-repeat 0% 0%/100% 100%;-moz-border-image:url(//www.google.com/images/branding/googlelogo/2x/googlelogo_color_150x54dp.png) 0}}@media only screen and (-webkit-min-device-pixel-ratio:2){#logo{background:url(//www.google.com/images/branding/googlelogo/2x/googlelogo_color_150x54dp.png) no-repeat;-webkit-background-size:100% 100%}}#logo{display:inline-block;height:54px;width:150px}
      </style>
      <a href=//www.google.com/><span id=logo aria-label=Google></span></a>
      <p><b>404.</b> <ins>That's an error.</ins>
      <p>The requested URL <code>/v1beta1/projects/jetpack-dev/locations/us-east1/clusters/projects/jetpack-dev/locations/us-east1/clusters/dev-gcp-us-east1/nodePools?alt=json&prettyPrint=false</code> was not found on this server.  <ins>That's all we know.</ins>
Here’s the resource definition:
Copy code
const nodepool = new gcp.container.NodePool(
      `${name}-pool2`,
      {
        cluster: cluster.id,
        location: config.require("region"),
        nodeCount: 1,
        autoscaling: {
          minNodeCount: 1,
          maxNodeCount: 10,
        },
        nodeConfig: {
          serviceAccount: serviceAccount.email,
          oauthScopes: ["<https://www.googleapis.com/auth/cloud-platform>"],
          machineType: "e2-standard-8",
          imageType: "UBUNTU",
        }
      },
      {
        provider: gcpProvider
      }
  );
am i missing something silly/simple here?
cc @billowy-army-68599 (sorry to ping you directly, but I think you may have some context on this)
s

sparse-park-68967

03/31/2022, 6:52 PM
what is the region config you are using? The error is a 404 - ignoring the html coming back, perhaps your location is invalid? You could also just drop the location if it needs to be in the same location as the cluster.
m

many-psychiatrist-74327

03/31/2022, 7:00 PM
Thanks Vivek! At first I thought it was the location (us-east1), but that seems to be fine. I think there’s a bug when you pass
cluster: cluster.id
. I changed it to use
cluster: cluster.name
and it worked fine
i tried that after i saw this other person with the same problem: https://github.com/pulumi/pulumi-gcp/issues/282#issuecomment-586022085
t

thousands-psychiatrist-31710

05/03/2022, 11:12 PM
Find a resolution, seeing the same error? It looks like Pulumi is trying to deploy a new node pool into a zone my Regional cluster is not configured to have nodes in
8 Views