getting a strange error when running `pulumi impor...
# general
getting a strange error when running
pulumi import aws:codepipeline/pipeline:Pipeline
Copy code
error: aws:codepipeline/pipeline:Pipeline resource 'staging-pipeline' has a problem: expected length of stage.0.action.0.namespace to be in the range (1 - 100), got . Examine values at 'Pipeline.Stages[0].Action[0].Namespace'.
Looks like it's complaining that namespace isn't there, but that's an optional property?
We're actively working on this! For now the only workaround is to write the resource in your program yourself and use
to import it in. We're looking at multiple things to improve this.
i'm not familiar with
, is there a blog post or resource online that details this workaround?
might be helpful to understand how you inform/connect pulumi to existing resources in the interim while these issues are worked out; i tried importing a few other resources and I wasn't able to import anything (as they all had derived/generated fields)
Specifically on that page the part about the import resource option.
ok; I think I understand, basically I have to manually define it and link the resource with the ID in AWS via
at which point Pulumi will connect the two
👍 1
any idea on when the CLI import functionality will be fixed?
We hope to ship improvements in the next few releases.
So possibly next Wednesday, but if not I'd really hope we can make the two weeks after that (23rd Feb)
ok, thank you for the update, trying to decide if we are going to use Pulumi for IoC and the import feature was really attractive.