https://pulumi.com logo
Title
e

echoing-midnight-60897

01/17/2022, 4:07 PM
I’ve been working on deploying an app using GitLab as CI/CD and using SSM parameters for storing config variables but have been getting this error:
Error Invoke of 'aws:ssm/getParameter:getParameter' failed: rpc error: code = Unknown desc = invocation of aws:ssm/getParameter:getParameter returned an error: invoking aws:ssm/getParameter:getParameter: Error describing SSM parameter: ParameterNotFound:status code: 400
error: update failed
I’ve verified the parameters, IAM permissions and values of the parameters and everything seems to be fine. It doesn’t give any parameter to check in specific where the error log isn’t being helpful. Any idea on how this can be resolved?
m

millions-furniture-75402

01/17/2022, 4:26 PM
Are you sure the plan is running against the correct AWS account?
e

echoing-midnight-60897

01/17/2022, 4:28 PM
Just verified, yes it is running against the correct account.
m

millions-furniture-75402

01/17/2022, 4:28 PM
Have you checked CloudTrail?
e

echoing-midnight-60897

01/17/2022, 4:28 PM
Yes, nothing helpful
m

millions-furniture-75402

01/17/2022, 4:29 PM
on-prem GitLab or SaaS?
e

echoing-midnight-60897

01/17/2022, 4:30 PM
On-prem
m

millions-furniture-75402

01/17/2022, 4:32 PM
could it be Firewall related?
e

echoing-midnight-60897

01/17/2022, 4:34 PM
So the weird part here is, the same code with same permissions is running fine in Dev but is failing in Test environment.
b

billowy-army-68599

01/17/2022, 4:58 PM
@echoing-midnight-60897 AWS will return this if you don't have permission to retrieve the parameter. check there's no policy blocking this
f

freezing-van-87649

01/17/2022, 6:07 PM
e

echoing-midnight-60897

01/17/2022, 6:59 PM
Great, going to try the above two and will update here.
👍 1
This ended up being an issue with the CI/CD tool that we’re using.
👍 1