is there a way to choose which version of typescri...
# typescript
is there a way to choose which version of typescript/ts-node pulumi uses? On 
pulumi preview
 I'm running into a compile error that should not exist on typescript version 4.4+ when using template literals the way I'm using them 
Object literal may only specify known properties
Update your package.json with the correct version range.
my package.json has these version, with the versions in the lockfile as higher than this
Copy code
"ts-node": "^10.2.1",
    "typescript": "^4.4.2"
CLI is using a different version of typescript. When I run similar code not through Pulumi CLI, I don't get an error.
Not in a first-class way, AFAIK, but this issue mentions a couple of workarounds, e.g., Yarn `resolutions`:
👀 1
👍 1