https://pulumi.com logo
#typescript
Title
# typescript
s

steep-toddler-94095

02/02/2022, 12:10 AM
is there a way to choose which version of typescript/ts-node pulumi uses? On 
pulumi preview
 I'm running into a compile error that should not exist on typescript version 4.4+ when using template literals the way I'm using them 
Object literal may only specify known properties
l

little-cartoon-10569

02/02/2022, 1:03 AM
Update your package.json with the correct version range.
s

steep-toddler-94095

02/02/2022, 1:15 AM
my package.json has these version, with the versions in the lockfile as higher than this
Copy code
"ts-node": "^10.2.1",
    "typescript": "^4.4.2"
the
pulumi
CLI is using a different version of typescript. When I run similar code not through Pulumi CLI, I don't get an error.
m

miniature-musician-31262

02/02/2022, 5:01 AM
Not in a first-class way, AFAIK, but this issue mentions a couple of workarounds, e.g., Yarn `resolutions`: https://github.com/pulumi/pulumi/issues/8177
👀 1
👍 1
7 Views