https://pulumi.com logo
#aws
Title
# aws
a

astonishing-quill-88807

03/29/2022, 2:28 PM
Has anyone been able to use an instance profile on an EC2 instance for authenticating with the default AWS provider? It seems like it defaults to disabling the EC2 metadata access and validating credentials. I was able to override those values and get things working on <5.0 but I'm hitting the same set of errors again after the update.
b

billowy-army-68599

03/29/2022, 2:32 PM
@astonishing-quill-88807 I think this was fixed in 5.1.0 of the provider
a

astonishing-quill-88807

03/29/2022, 2:32 PM
Thanks! I'll give that a try
Looks like we're actually already running 5.1.0 and still hitting this error. Has there been any movement on flipping the default bit for EC2 metadata access in the provider? https://github.com/pulumi/pulumi-aws/issues/1692
b

billowy-army-68599

03/29/2022, 6:53 PM
I don't think there's any movement on the defaults, if you set the env var/config value it should work
a

astonishing-quill-88807

03/29/2022, 7:36 PM
Unfortunately the env var doesn't seem to be having any impact
The config value was working on <5.x but doesn't appear to be functional on 5.1
b

billowy-army-68599

03/29/2022, 8:01 PM
okay, that's definitely a bug. could you file an issue?
b

broad-dog-22463

03/29/2022, 9:34 PM
Hi @astonishing-quill-88807 - what env var were you setting?
a

astonishing-quill-88807

03/29/2022, 10:06 PM
I was using
AWS_EC2_METADATA_DISABLED=false
b

broad-dog-22463

03/29/2022, 10:16 PM
Ok I'll look into this for you
a

astonishing-quill-88807

03/30/2022, 12:38 AM
I appreciate it!
9 Views