So i have been waiting for this fix to be released...
# aws
s
So i have been waiting for this fix to be released. It adds support for dotnet6 managed lambdas: https://github.com/pulumi/pulumi-aws/pull/1840 It seems to be a part of pulumi-aws 4.38.0 (https://github.com/pulumi/pulumi-aws/releases/tag/v4.38.0),  but when i upgraded to this version I still get the same error that I reported in the first place. I can see that the package contains the fix, but I have hard time debugging to figure out exactly where the error message origins: The error message:
aws:lambda/function:Function resource ’name-of-lambda has a problem: expected runtime to be one of [nodejs nodejs4.3 nodejs6.10 nodejs8.10 nodejs10.x nodejs12.x nodejs14.x java8 java8.al2 java11 python2.7 python3.6 python3.7 python3.8 python3.9 dotnetcore1.0 dotnetcore2.0 dotnetcore2.1 dotnetcore3.1 nodejs4.3-edge go1.x ruby2.5 ruby2.7 provided provided.al2], got dotnet6. Examine values at ‘Function.Runtime’.
Version 4.38.0 does contain dotnet 6:
Copy code
export declare const Runtime: {
  readonly DotnetCore2d1: “dotnetcore2.1”;
  readonly DotnetCore3d1: “dotnetcore3.1";
  readonly Dotnet6: “dotnet6”;            <————— HERE
  readonly Go1dx: “go1.x”;
  readonly Java8: “java8”;
  readonly Java8AL2: “java8.al2";
  readonly Java11: “java11”;
  readonly Ruby2d5: “ruby2.5";
  readonly Ruby2d7: “ruby2.7”;
  readonly NodeJS10dX: “nodejs10.x”;
  readonly NodeJS12dX: “nodejs12.x”;
  readonly NodeJS14dX: “nodejs14.x”;
  readonly Python2d7: “python2.7”;
  readonly Python3d6: “python3.6";
  readonly Python3d7: “python3.7”;
  readonly Python3d8: “python3.8";
  readonly Custom: “provided”;
  readonly CustomAL2: “provided.al2";
};
Can anyone help for a quick fix?
s
Looking at this now, and sorry this is so troublesome!
I'm gonna comment on the issue, but it may be possible that
dotnet6
is not supported in the AWS API yet.
Nope - ignore. They just need to update their docs. We have to wait until terraform-provider-aws 4.4, but I know y'all are waiting on that update, so we'll get it our update released ASAP.
🙌 1
s
@stocky-restaurant-98004 This has been released now. Do you know how long it “ususally” takes before this change is released? 😅 I guess your bot has created the issue: https://github.com/pulumi/pulumi-aws/issues/1847
s
Sorry for the delay. We're actively working on it but running into a potential upstream bug we need to work out.
Our usual turnaround for the major cloud providers is 2 days, but we also had to work through the recent changes with 4.0 and the S3 bucket change that happened upstream. (We were able to maintain backwards compatibility.)
🙌 1
148 Views