h

    high-leather-15669

    8 months ago
    Hello, I am trying to create a Disk Encryption Set in Azure, and get the following error:
    cannot check existence of resource '/subscriptions/xxx/resourceGroups/%2Fsubscriptions%xx%2FresourceGroups%2Fxxx/providers/Microsoft.Compute/diskEncryptionSets/des-xxx': status code 400, {"error":{"code":"InvalidApiVersionParameter","message":"The api-version '2020-12-01' is invalid. The supported versions are '2021-04-01,2021-01-01,2020-10-01,2020-09-01,2020-08-01,2020-07-01,2020-06-01,2020-05-01,2020-01-01,2019-11-01,2019-10-01,2019-09-01,2019-08-01,2019-07-01,2019-06-01,2019-05-10,2019-05-01,2019-03-01,2018-11-01,2018-09-01,2018-08-01,2018-07-01,2018-06-01,2018-05-01,2018-02-01,2018-01-01,2017-12-01,2017-08-01,2017-06-01,2017-05-10,2017-05-01,2017-03-01,2016-09-01,2016-07-01,2016-06-01,2016-02-01,2015-11-01,2015-01-01,2014-04-01-preview,2014-04-01,2014-01-01,2013-03-01,2014-02-26,2014-04'."}}
    Any idea why?
    When it happens twice, you realize that it is something wrong between the keyboard and chair. #PEBKAC Leaving this in case someone has the same problem.. I have been giving the input resource_groupinstead of
    resource_group.name