https://pulumi.com logo
#general
Title
# general
l

lively-helmet-97905

05/12/2022, 7:22 PM
Hello, I need some help. Im getting this error with Github actions:
getting credentials: exec plugin is configured to use API version <http://client.authentication.k8s.io/v1beta1|client.authentication.k8s.io/v1beta1>, plugin returned version <http://client.authentication.k8s.io/v1alpha1|client.authentication.k8s.io/v1alpha1>
Any walkaround of how to solve this ?
b

billowy-army-68599

05/12/2022, 7:48 PM
update your AWS cli version
l

lively-helmet-97905

05/12/2022, 7:54 PM
I was searching on internet and I see that it refers to kubectl binary version.
Im using Github Actions for this case.
Can I use https://github.com/Azure/setup-kubectl to install the 1.23 version of kubectl ?.
Also, do you have any guide of how to install aws-cli in a github action runner ?
b

billowy-army-68599

05/12/2022, 7:55 PM
oh sorry yes, are you provisioning an EKS cluster?
l

lively-helmet-97905

05/12/2022, 7:56 PM
Yes, I have an eks cluster created already.
b

billowy-army-68599

05/12/2022, 7:58 PM
yep, its the aws cli version: https://github.com/pulumi/pulumi-eks/issues/600 update it, I'm not sure how to do that in github actions, I'm sure there's a setup aws cli action
l

lively-helmet-97905

05/12/2022, 8:00 PM
by default the ubuntu runner that im using brings these versions: ā€¢ AWS CLI 2.6.1 ā€¢ AWS CLI Session manager plugin 1.2.312.0
Which version is the recommended to fix this ?
b

billowy-army-68599

05/12/2022, 8:01 PM
not entirely sure I'm afraid, which version of eks are you using?
l

lively-helmet-97905

05/12/2022, 8:01 PM
I have a version by default more newer that the described in the url that you sent me.
Im using eks 1.18
b

billowy-army-68599

05/12/2022, 8:02 PM
sorry, the eks pulumi package
l

lively-helmet-97905

05/12/2022, 8:03 PM
Copy code
"dependencies": {
        "@pulumi/aws": "^3.2.1",
        "@pulumi/awsx": "^0.22.0",
        "@pulumi/kubernetes": "^2.5.1",
        "@pulumi/pulumi": "^2.0.0"
    }
I have these packages defined already.
b

billowy-army-68599

05/12/2022, 8:03 PM
upgrade your awsx version
l

lively-helmet-97905

05/12/2022, 8:03 PM
To which one ?. Can you please give me the good version ?
b
l

lively-helmet-97905

05/12/2022, 8:13 PM
Thanks
Im getting the same error.
Empty KUBERNETES_EXEC_INFO, defaulting to client.authentication.k8s.io/v1alpha1. This is likely a bug in your Kubernetes client. Please update your Kubernetes client.
šŸ˜ž.
b

billowy-army-68599

05/12/2022, 8:45 PM
that appears to be a different error, can you share your code and GitHub action configuration?
l

lively-helmet-97905

05/12/2022, 8:48 PM
Sure, I will share the code with you using PM.
a

adamant-father-26302

05/23/2022, 3:46 PM
Hi, im also having this issue, after upgrading to pulumi-eks-0.40.0 & pulumi-aws/sdk/v5-v5.1.2. (upgraded both at the same time) using aws-cli/2.5.6
seems upgrading to
aws-cli/2.7.2
worked. kindof difficult to figure that out from that error
23 Views