Thread
#kubernetes
    l

    lively-helmet-97905

    4 months ago
    Hello, I need some help. Im getting this error with Github actions:
    getting credentials: exec plugin is configured to use API version <http://client.authentication.k8s.io/v1beta1|client.authentication.k8s.io/v1beta1>, plugin returned version <http://client.authentication.k8s.io/v1alpha1|client.authentication.k8s.io/v1alpha1>
    Any walkaround of how to solve this ?
    p

    polite-napkin-90098

    4 months ago
    I think this is the issue where you need to downgrade kubectl to match your server version
    l

    lively-helmet-97905

    4 months ago
    Im using eks 1.18, so, I need to install kubectl 1.18 ?
    s

    sparse-park-68967

    4 months ago
    Apologies for the issues here. A fix has been merged and v0.40.0 release is underway which should include a fix to address this.
    Essentially kubectl v1.24.0 removed the API version for client.authentication.k8s.io/v1alpha1. If you use a slightly older kubectl you could get around it (1.23.6). 0.40.0 should allow it to work with the latest aws-cli