k

    kind-island-70054

    4 months ago
    Hello ! I’m trying to deploy the firestore rules file I have through Pulumi. I use
    new gcp.firebaserules.Ruleset(
        "firestore-rules",
        {
          project: gcp.config.project,
          source: {
            files: [
              {
                content: fs
                  .readFileSync(path.resolve(__dirname, "../../firestore.rules"))
                  .toString(),
                name: "firestore.rules",
              },
            ],
          },
        },
        { dependsOn: services }
      );
    I have enabled the firebaserules service this way:
    new gcp.projects.Service("firebaserules", {
      service: "<http://firebaserules.googleapis.com|firebaserules.googleapis.com>",
    });
    But I receive a SERVICE_DISABLED error when I run pulumi up:
    [
          {
            "@type": "<http://type.googleapis.com/google.rpc.ErrorInfo|type.googleapis.com/google.rpc.ErrorInfo>",
            "domain": "<http://googleapis.com|googleapis.com>",
            "metadata": {
              "consumer": "projects/764086053860",
              "service": "<http://firebaserules.googleapis.com|firebaserules.googleapis.com>"
            },
            "reason": "SERVICE_DISABLED"
          }
        ]
    That project number is not mine weirdly… It also gives me this error message but I don’t think that it’s related to my problem, is it?
    Error creating Ruleset: googleapi: Error 403: Your application has authenticated using end user credentials from the Google Cloud SDK or Google Cloud Shell which are not supported by the <http://firebaserules.googleapis.com|firebaserules.googleapis.com>. We recommend configuring the billing/quota_project setting in gcloud or using a service account through the auth/impersonate_service_account setting. For more information about service accounts and how to use them in your application, see <https://cloud.google.com/docs/authentication/>. If you are getting this error with curl or similar tools, you may need to specify 'X-Goog-User-Project' HTTP header for quota and billing purposes. For more information regarding 'X-Goog-User-Project' header, please check <https://cloud.google.com/apis/docs/system-parameters>.
    Is there an additional service to enable that I don’t know about maybe? Has anybody encountered a similar error?
    It actually seems to be helpful since authenticating as a service account using
    gcloud auth activate-service-account
    with a keyfile works well
    w

    white-crayon-65245

    3 months ago
    I'm seeing this same
    SERVICE_DISABLED
    error when trying to create a new pubsub topic -- it tries to create the resource in a totally different project from the one specified in the code
    it turned out the user we were trying to run the deploy with didn't have proper permissions