Thread
#general
    r

    rich-agency-75207

    3 months ago
    In case relevant: My subnetwork's purpose is set to
    PRIVATE_RFC_1918
    e

    echoing-dinner-19531

    3 months ago
    Are you setting the "network" property for the address?
    r

    rich-agency-75207

    3 months ago
    yes
    I haven't specified an explicit static IP address tho... I assumed that if not defined - google cloud will auto-generate the address...
    I want to reference the
    address
    generated in another dependent resource
    e

    echoing-dinner-19531

    3 months ago
    Yeh just trying to find any docs about this
    So does your terraform and pulumi code look to be setting the same properties? But TF works and Pulumi errors about no default subnet?
    r

    rich-agency-75207

    3 months ago
    correct
    e

    echoing-dinner-19531

    3 months ago
    Odd I think both should just be sending pretty much the same request to GCP. Might be the request is sensitive to something like null vs missing fields. Could you raise an issue at https://github.com/pulumi/pulumi-google-native about this? If you can share how your working terraform resource is configured as well that would help.
    r

    rich-agency-75207

    3 months ago
    I'll test using legacy gcp provider too