Hello! I'm moving our Cloud Run resources to pulum...
# google-cloud
Hello! I'm moving our Cloud Run resources to pulumi from being deployed with Cloud Build.
pulumi update
keeps getting hung up on pending operations. Do I need to remove the existing services and let Pulumi bring them up, start clean?
I ran in to the same issue earlier. what helped me was setting the following parameter:
autogenerateRevisionName: true
and making sure I run a
pulumi refresh
pulumi up
you can combine both as well by running
pulumi up --refresh
Oh, is revision name the Pulumi name, or the GCP service name?
In a related problem, if I rename an
, I seem to get stuck forever in 'deleting'.
Copy code
Type                       Name                            Status       Info
     pulumi:pulumi:Stack        tokens-secrets-dev              running      
 ~   ├─ gcp:cloudrun:Service    nocap-api-demo                  updated      [diff: ~template]
 +   ├─ gcp:cloudrun:IamPolicy  nocap-api-demo-NoauthIamPolicy  created      
 -   └─ gcp:cloudrun:IamPolicy  nocap-api-demoNoauthIamPolicy   deleting...
requires a defined name, doesn't it? but it seems to hang when deleting the old one after creating a new name.
Eventually, it comes back with
Copy code
  gcp:cloudrun:IamPolicy (nocap-api-demoNoauthIamPolicy):
    error: deleting urn:pulumi:dev::tokens-secrets::gcp:cloudrun/iamPolicy:IamPolicy::nocap-api-demoNoauthIamPolicy: 1 error occurred:
        * Error setting IAM policy for cloudrun service "v1/projects/nocap-demo/locations/us-central1/services/nocap-api-demo": googleapi: Error 409: There were concurrent policy changes. Please retry the whole read-modify-write with exponential backoff. The request's ETag '\007\005\341\006RR\211\336' did not match the current policy's ETag '\007\005\341\006Z\354J\351'.
Oh, but the
you suggested clears that up. Okay!