might be a provider question, might be an Azure qu...
# general
might be a provider question, might be an Azure question. I'm creating an Azure RoleAssignment - and this has worked before - now I disabled the azure provider, and instantiated my own (but note: I didn't pass it to anything - I just instantiated it). When I create the RoleAssignment, pulumi up complains with: azure-nativeauthorizationRoleAssignment (sreg-role-assignment): error: autorest/azure: Service returned an error. Status=404 Code="ResourceGroupNotFound" Message="Resource group 'x25container6750c5ea' could not be found." The interesting part is that the resource group isn't specified anywhere that I can see in the definition of the RoleAssignment. So I wonder what's going on? Culprits in my mind would be: the provider, maybe the Service Principal rights. How might I debug this further?
the answer is: I had a ComponentResourceOptions instance which was setting a field value. Once I removed the entire instance, the creation worked.
therefore, the default provider appears to be picked up if ComponentResourceOptions is null?