Hello, I had "override_main_response_version" opti...
# general
Hello, I had "override_main_response_version" option enabled in the OpenSearch, even after removing it from index.ts, still Pulumi not deleting it from the stack. There is a diff between running stack and template. Any help. I see same problem was faced before but couldn't see the solution. https://pulumi-community.slack.com/archives/C84L4E3N1/p1632272442488400
Although I don't use OpenSearch, my experience with the persistent defaults so far was that it helped to define explicitly the inputs related to the diffs. So, if you removed "override_main_response_version" from index.ts, then put it back in as an explicit "override_main_response_version: false". Your diff might go away, and if not, then try
pulumi refresh
followed by one more
pulumi up
@cuddly-magician-97620 Unfortunately no luck. Tried both the steps. Also I tried to upgrade/downgrade the aws-native version but still same error.
aws-native:opensearchservice:Domain (ix-dev_apps_eks_openSearch_cluster):
error: operation UPDATE failed with "InvalidRequest": Invalid request provided: Unrecognized advanced option 'override_main_response_version' passed in advancedOptions. (Service: OpenSearch, Status Code: 400, Request ID: 8acf540a-88b3-469a-8cbb-57cf28a7b24a)
It was not a bug but I did not see this error after I added "advancedOptions:{}"