Hey there - if anyone is already using federated c...
# azure
Hey there - if anyone is already using federated credentials - Is it possible to use federated credentials in Azure with branch wildcards?
Hey John. AFAIK you are not able to do wildcards. You could do environments instead if you have the enterprise plan.
Hmmm, how do people then use federated credentials to handle all the builds for a non-master branch? Kinda assumes we're all living in a world of trunk based development, which sure as heck ain't what I've experienced in the field 🙂
and no, I don't wanna create a federated credential per branch.... hmmmmm... I wonder if I could get my azure devops system to tell me via webhook and then auto-create a federated credential that way... hmmmm...
Did you manage to get it working at all? A few weeks back it worked for me, but after a while the Pulumi cli started complaining about using the CLI to login instead of a Service Principal 😒
I got it working for a main branch - but only ran it a couple of times before coming across the feature branch problem which made me stop in my tracks.
Hmm It's just so weird. I started getting a
azure-native:resources:ResourceGroup rg-app-test  error: building auth config: Authenticating using the Azure CLI is only supported as a User (not a Service Principal).
... out of the blue
It worked the prior week and then suddenly not.
Do you mind me asking how you are authenticating to azure using workload identity federation?
Isn't that related to another env var, I've seen this. Can't reply right now as I'm at a swimming g pool. Hah.
😄 1
I've set a reminder in this chat for tomorrow.
Hmm It might be, but doesn't make any sense I think 😄 Awesome, thanks for that. I would appreciate that.
I figured it out, finally!
This works:
This does not work
await Pulumi.Deployment.RunAsync(() => { ... });