06/19/2022, 3:58 PM
I came back to my pulumi project after a while away, which involved getting a new laptop (apple M1) it seems like I have this problem i.e. the Digital Ocean provider - I had been using v3.1.1 but I can’t install that on my new laptop, and if I install latest version it can’t refresh the stack the instructions for fixing it sound simple:
1. Open your Pulumi program on a non-arm64 based computer
2. Update your packages (pip / nuget / npm / go) and run
pulumi up
3. Once the update is complete, you can open the new, updated Pulumi program on your arm64-based system
I booted up a
docker container and cloned my project, installed pulumi but actually I am not sure what to do next I have installed the old version of the provider… do I install the latest version too? and then if I
pulumi up
it can get state using the old provider, and will update it using latest version? not really clear what the fix is here


06/19/2022, 4:09 PM
hi, yes you've got it right. You need the new and old versions of the plugin. The best way is to install the deps with your package manager, then updated your deps there too


06/23/2022, 11:42 AM
this didn't work... in my docker container
pulumi plugin ls
cloudflare    resource  4.7.0    38 MB  n/a        1 day ago
cloudflare    resource  2.8.0    46 MB  n/a        1 day ago
digitalocean  resource  4.14.0   42 MB  n/a        1 day ago
digitalocean  resource  3.1.1    45 MB  n/a        1 day ago
I ran
pulumi up
from there successfully but when I go back to my local shell and
pulumi preview
I still get:
error: could not load plugin for digitalocean provider 'urn:pulumi:staging::myproject::pulumi:providers:digitalocean::default': no resource plugin 'pulumi-resource-digitalocean' found in the workspace at version v3.1.1 or on your $PATH, install the plugin using `pulumi plugin install resource digitalocean v3.1.1`