11/08/2022, 2:23 PM
Issues with Pulumi K8 provider related when used with automation api - I am getting this error when deploying a "deployment" using pulumi automation API. It seems like it is expecting the aws cli command. How can we use this with autoamtion api? Or is there another method (certs?). [background - i have an eks cluster already deployed using the automation api using iam roles etc.] Error--- + kubernetes:apps/v1:Deployment id3 creating failed error: configured Kubernetes cluster is unreachable: unable to load schema information from the API server: Get "": getting credentials: exec: executable aws not found -------- This is the config part for users in kubeconfig users: - name: arn:aws:eks:us-west-1:XXXXXXXXXXXXXXX:cluster/eks-clu01a user: exec: apiVersion: args: - --region - us-west-1 - eks - get-token - --cluster-name - eks-clu01a command: aws


11/08/2022, 3:00 PM
Hi, AFAIK the aws cli is indeed a requirement ( or aws-iam-authenticator , never tried this ). We also use the automation API and we simply make sure it's installed ( it's a bummer though )


11/08/2022, 3:28 PM
ok. thanks. i believe there is an option to use certs etc but we haven't tried..