https://pulumi.com logo
#aws
Title
# aws
e

enough-pager-36335

11/23/2022, 11:02 AM
I'm setting up EC2 services over ECS using Auto Scaling Groups, there's this weirdest bug I can'g seem to solve, my pulumi up update is stuck on read awsautoscalingGroup Running the exact same code on another machine works perfectly somehow. Anyone might know what can cause this? I have tried running destroy and then up again, I have tried pulumi refresh, I have even tried deleting and reinstalling pulumi on my machine, thanks.
m

melodic-tomato-39005

11/23/2022, 2:37 PM
The difference from machine to machine makes me think of authentication. Is reading the autoscaling group the first thing the program does? Or are there other AWS operations that succeed?
e

enough-pager-36335

11/23/2022, 3:13 PM
everything else succeed, the machine and credentials are the same that ran the first pulumi up for this stack It looks like the whole operation is finished (including building the docker image and uploading it) yet the update is stuck (also no new logs written for more than a few minutes). On another machine everything works fine.
2 Views