11/24/2022, 8:20 AM
When I run pulumi update command inside circleci I receive this error:
Error: Failed to parse kubectl version JSON output
but when I run it locally it works. This happened after I update some of the circleci orbs and pulumi plugins to the newest versions:
// circleci config
  node: circleci/node@4.5.1
  aws-cli: circleci/aws-cli@3.1.3
  aws-ecr: circleci/aws-ecr@7.0.0
  pulumi: pulumi/pulumi@2.1.0
  shellcheck: circleci/shellcheck@2.2.4
  kubernetes: circleci/kubernetes@1.3.1

// package.json
  "dependencies": {
    "@pulumi/aws": "^5.21.1",
    "@pulumi/awsx": "^0.40.1",
    "@pulumi/eks": "^0.42.7",
    "@pulumi/kubernetes": "^3.22.1",
    "@pulumi/pulumi": "^3.47.2"
When I see output from pulumi program inside circleci it looks something like this:
  - cidr            : ""
  - provider        : {
      - id        : "some-id"
      - kubeconfig: (json) {
          - apiVersion     : "v1"
          - clusters       : [
But by running it locally I have output in this format:
cidr            : ""
    provider        : {
        id        : "some-id"
        kubeconfig: (json) {
            apiVersion     : "v1"
            clusters       : [
                [0]: {
                    cluster: {
It looks to me that error is thrown because of different output format, but how to change it? This is my pulumi program output:
module.exports = {
  publicSubnetIds: pulumi.output(vpc.publicSubnetIds),
  privateSubnetIds: pulumi.output(vpc.privateSubnetIds),
  cidr: vpc.vpc.cidrBlock,
  provider: cluster.provider
Before updating orbs and pulumi plugins I didn’t have this issue, output was the same both locally and on circleci but I had to update plugins because I was receiving:
Kubeconfig user entry is using deprecated API version <|>. Run 'aws eks update-kubeconfig' to update.
error so I had to make update Does anyone know what is the issue? Thanks in advance 🙌


11/24/2022, 3:21 PM


11/26/2022, 4:45 PM
@billowy-army-68599 Yeah I saw that stack overflow post and I updated everything, but now I am receiving other error as mentioned above:
Error: Failed to parse kubectl version JSON output
I downgrade pulumi eks plugin to version 0.40.0 instead of the newest version 0.42.7 and it seems it works now