https://pulumi.com logo
Title
k

kind-keyboard-17263

06/22/2022, 11:02 AM
Hi ! I have a weird behaviour here. If I login by
pulumi login
the procedure happens correctly; but if I try to provide a cloud bucket (
pulumi login gs://<bucket name>
) the authentication goes somehow wrong, with a different result, and when I try to run whatever command (eg:
pulumi preview
) I receive a 403 because it thinkgs I am logged in (gcp) with the wrong identity (while it's not true, because I have tested this while also anonymous). I don't understand how the login procedure can be different when passing the bucket (which has already been used with success). Also, when I login without bucket info, the message such that I recognize the proper username, while if I login with gs info, I obtain:
Logged in to DESKTOP-UOHVP03 as bruno (gs://<bucket name>)
This is the non working setup (the bruno usernema is totally wrong), while:
Logged in to <http://pulumi.com|pulumi.com> as xxxx (address)
is the working one. It looks like the gs option triggers a local version of the authentication. Thanks for help !
e

echoing-dinner-19531

06/22/2022, 2:16 PM
If your using a bucket object then your pulumi user is just whatever your local computer user is.
k

kind-keyboard-17263

06/22/2022, 2:17 PM
I am not sure I understand. I was already using this setup, what changed is that I changed for 1 day the gcloud identity. But now everything is back to the original one, so I'd expect everything to work
what am I doing wrong ?
e

echoing-dinner-19531

06/22/2022, 2:19 PM
Logged in to DESKTOP-UOHVP03 as bruno (gs://<bucket name>)
The username in that message is just whatever os.Hostname returns