# general


06/24/2022, 8:27 AM
On a related note - the reason I am using a file is down to an issue using a multi-line yaml string definition:
Copy code
kubeconfig: |
  apiVersion: v1
This momentarily worked when I defined this way. Then, a few hours later, pulumi cli started to error. i.e. it worked w/o issue but now it does not:
error: receiver must be a list or object, not nili
receiver must be a list or object, not nil
error: an unhandled error occurred: waiting for RPCs: marshaling properties: awaiting input property kubeconfig: runtime error
Has there been an update to the Pulumi backend over the last 24 hours. Some properties of a kubernetes cluster resource were, previously, available. It seems pulumi returns
now for some of them including
If so, I would understand such a move considering the sensitivity of this data.
Also, for added context, my inspiration to create a custom k8s provider and manual kubeconfig came from this Pulumi article:
Perhaps it is no longer relevant in context to Google's latest security standard and use of a cert..?
Please note - when I tested ^ locally - it works. ./kube/config is removed to ensure no authority exists that would facilitate a Pulumi --> GKE K8s API request. kubectl tested as not work to confirm expected behaviour
pulumi up
does work. I have tested creation of k8s objects via pulumi including updates and deletion.
pulumi does not throw any errors on invocation and am using a custom-provider that references
However, after some time, pulumi does start to throw the error.
Root cause is
starts to return
Is this expected behaviour?
Having eyeballed the
property value, via | Stack | resources - I can also confirm that the
entry is still there and valid.