Hi everyone :slightly_smiling_face: I can’t manage...
# kubernetes
Hi everyone 🙂 I can’t manage to update my EKS cluster’s kubeconfig after upgrading to v 1.22. No matter what i do:
Copy code
  kubernetes:core/v1:ConfigMap (tezos-aws-tutorial-nodeAccess):
    error: failed to initialize discovery client: exec plugin: invalid apiVersion "<http://client.authentication.k8s.io/v1alpha1|client.authentication.k8s.io/v1alpha1>"
I’ve updated the k8s version on AWS, and pulumi refreshed. I’ve also updated my pulumi packages to the latest versions as well as aws-cli and kubectl. (Although it seems kubectl 1.24 is broken so i went back down to 1.22) I’ve also manually modified my stacks state. I changed
"apiVersion": "<http://client.authentication.k8s.io/v1alpha1|client.authentication.k8s.io/v1alpha1>"
to use
and changed the EKS provider version to
"version": "0.41.0"
No matter what i do pulumi gives me the error, and
pulumi stack output kubeconfig --show-secrets -j
shows the old kubeconfig version using
what does
pulumi about
a large output 🙂
is the eks in your current pulumi program?
yes, i have a cluster already. i was trying to update all of the libraries. It seemed i couldn’t just update the libraries alone and have pulumi work. I kept getting the same error. So then i manually on the AWS console updated the EKS versions. Then i refreshed pulumi which worked. But i still cannot run pulumi up
any chance I can get a copy of your pulumi program?
it’s essentially this. https://github.com/oxheadalpha/tezos-pulumi/blob/main/examples/tutorial/index.ts Right now i’m only dealing with the VPC and cluster and not the rest of the code
do you have
version: "1.22"
between like 63 and 73? also can you
yarn add "@pulumi/eks@0.41.0"
yarn add "@pulumi/kubernetes@3.19.4"
then see if you can
pulumi up
do you have
version: "1.22"
nope but i tried and didn’t help. Also it defaults to latest version anyways Also my node_mods have that version of k8s, even though it isn’t a top level pacakge in my pkg.json
also for some reason i am getting
warning "@oxheadalpha/tezos-pulumi > @pulumi/awsx@0.31.0" has incorrect peer dependency "@pulumi/aws@^4.6.0".
So i needed to install pulumim/aws even though in general i don’t need to do that
Thanks for trying to help… this is really blocking me though. I’m going to try spinning up an entirely new cluster
and then i also have this
warning " > @pulumi/awsx@0.40.0" has incorrect peer dependency "@pulumi/aws@^5.0.0".
dependencies are messed up it seems in pulumi pkgs
i can’t even create a new cluster bec of these dependency issues…. Am i doing something wrong?
yes share your
hmmmmi think i finally got it to work after many iteratinos of deleting node_mods and reinstalling things. i’m not sure what i finally did right. Thank you very much for your help. Cluster is still spinning up a node but it should be fine as i got past my original issue
you installed the correct dependencies 🙂
yes finally. I don’t know why it wasnt working. i kept installing
hmmm but now my cluster node isn’t getting
<http://kubernetes.io/cluster/tezos-aws-tutorial-eksCluster-573fba5|kubernetes.io/cluster/tezos-aws-tutorial-eksCluster-573fba5>: owned
set automatically
Shouldn’t that happen by itself? I needed to set it so that my cluster recognized the node