https://pulumi.com logo
#python
Title
# python
g

gentle-advantage-80069

07/10/2022, 10:25 AM
Hi, I want to use a dedicated venv for gcp-python project, but the problem is i can't find a way to provide the python venv path when running "pulumi new ...." It always creates a new venv in the project dir. how can i tell pulumi to use a set of config values for both "pulumi.yaml and pulumi.<stack>.yaml" while running "pulumi new ..." ??
pulumi new gcp-python --name="mongodb-atlas" --stack="dev" --dir="/Users/saad*/Documents/sada-systems/pulumi/mongodb" --secrets-provider="*****"--description="Pulumi Project to manage MongoDB Atlas" ---------- This is what am running as of now, but it still prompts me to provide the gcp-project-id , even though am sending it in config-file and also the its creating default venv inside the current dir
g

gentle-advantage-80069

07/10/2022, 6:09 PM
thanks, yea i figured out the venv, however if you can please help me with the 2nd query above ? I need to set the gcp config values while creating the project itself, so am using the project "template" section to set the values, but its still prompting me for gcp:project-id, even though i pass it in the template:
Copy code
name: mongodb
description: MongoDB Atlas project
runtime: python
  options:
    virtualenv: /Users/saaduddin/Documents//pulumi/virtualenv/venv
backend:
  url: <gs://pulumi_backend_state_bucket/>
template:
  description: A minimal Google Cloud Python Pulumi program
  important: true
  config:
    gcp:project:
      description: test 
      default: project-a
    gcp:region:
      description: The Google Cloud project to deploy into
      default: us-central1
even after passing the values in the template section, the default values aren't picked, it is still prompting to enter values, could you please help me address this
b

billowy-army-68599

07/10/2022, 6:15 PM
please open an issue if the default isn’t working
4 Views