https://pulumi.com logo
#azure
Title
# azure
a

ancient-solstice-53934

07/19/2022, 8:14 AM
I am suddenly started getting this issue. Earlier it was working 2022-07-19T080031.6135610Z Diagnostics: 2022-07-19T080031.6136187Z azurekeyvaultKeyVault (vault): 2022-07-19T080031.6138404Z error: Error reading resource group: resources.GroupsClient#Get: Failure responding to request: StatusCode=403 -- Original Error: autorest/azure: Service returned an error. Status=403 Code="AuthorizationFailed" Message="The client '63f4427e-993c-4160-9dd6-e5731454b566' with object id '63f4427e-993c-4160-9dd6-e5731454b566' does not have authorization to perform action 'Microsoft.Resources/subscriptions/resourcegroups/read' over scope '/subscriptions/c4ef5634-9b63-482c-9c5a-8a19aa8b47a6/resourcegroups/RG-CL-US-AppleServices-Dev' or the scope is invalid. If access was recently granted, please refresh your credentials." Microsoft.Resources/subscriptions/resourcegroups/read permissions already there. It works for same resource group from other stack
b

billowy-army-68599

07/19/2022, 2:55 PM
have your credentials expired?
a

ancient-solstice-53934

07/19/2022, 2:57 PM
Hi Jax, Thanks for reply. Which Credentials?
b

billowy-army-68599

07/19/2022, 2:57 PM
the ones you’re using tyo authenticate to azure
a

ancient-solstice-53934

07/19/2022, 3:27 PM
No, I am using same credentials from other stack with same configurations and Resource group and it works
b

billowy-army-68599

07/19/2022, 3:43 PM
same subscription? the error being returned is coming from the Azure API, so there must be some credential issue somewhere
a

ancient-solstice-53934

07/19/2022, 3:57 PM
Yes Jax, same Subscription, same resource group
17 Views