a

    alert-spoon-97538

    2 months ago
    Trying to run Pulumi in GitHub Action CI but keep seeing the following line implying a Profile is passed even though no AWS profile is defined.
    A Profile was specified along with the environment variables "AWS_ACCESS_KEY_ID" and "AWS_SECRET_ACCESS_KEY". The Profile is now used instead of the environment variable credentials. This may lead to unexpected behavior.
    I do set the config aws😛rofile locally and I tried removing that in the CI prior to
    up
    and re-adding it after though that didn't change the log line above. Is this an issue or a red herring?
    The reason I even started going down this path was after configuring the AWS cli I spit out the AWS config and I'm currently seeing the following ....
    Name                    Value             Type    Location
          ----                    -----             ----    --------
       profile                <not set>             None    None
    access_key     ****************ISEZ              env    
    secret_key     ****************0alB              env    
        region                us-east-1              env    ['AWS_REGION', 'AWS_DEFAULT_REGION']
    b

    billowy-army-68599

    2 months ago
    @alert-spoon-97538 the profile might be set inside the stack configuration, if you run a successful up with a config setting it gets passed to the stack config
    a

    alert-spoon-97538

    2 months ago
    I tried running
    pulumi config rm aws:profile
    right before
    pulumi up
    to see if that changed anything and it did not
    l

    little-cartoon-10569

    2 months ago
    Is it specified in code? When you construct the provider? Search for all provider constructors.
    a

    alert-spoon-97538

    2 months ago
    provider
    isn't used in the code at all
    l

    little-cartoon-10569

    2 months ago
    Have you output the value of AWS_PROFILE as seen by the CI job? Maybe that'll give you a hint where the value is coming from. Maybe an earlier step / action is setting it?
    a

    alert-spoon-97538

    2 months ago
    good idea
    nope