Anyone that has provisioned an aks cluster and the...
# azure
Anyone that has provisioned an aks cluster and then want to update the node pools? I thought changing the kubernetes version on the
would do, but apparently the node pools has their own version set somewhere else. I configure the node pools in the
property, but I can't see anything with version there.
Creating a new node pool wasn't the correct thing to do 🙂 Seems like renaming the node pool deleted everything... will the same thing if I just add a node pool. I really struggle to see how I will update a node pool...
Under agent pools there an orchestratorVersion option which sets the node pool Kubernetes version. Also read the note by the orchestratorVersion option about upgrades.
👍 1
Will test some tonight. Thanks. 🙏
Tested it now and it almost worked @clean-truck-93285. The node pool and cluster itself was updated, but pulumi up never finished when doing the uprade of the kubernetes version. Have you tried and got it working? All I did was basically provision a cluster and then changed the version and ran pulumi up again.
and right when I was writing this it actually finished 😂