https://pulumi.com logo
Title
i

icy-doctor-13719

01/06/2023, 4:43 AM
pulumi up
throwing an error … started about 20m ago … any ideas?
error: an unhandled error occurred: Program exited with non-zero exit code: 137
same with
preview
i’ve tried uninstalling / reinstalling pulumi … even tried deleting all of my code except a single resource. same error
on 3.51.0
installed some earlier versions (macOS) and same error
is there some sort of outage?
w

white-balloon-205

01/06/2023, 6:37 AM
Sorry for the trouble @icy-doctor-13719. No - there is not an outage, and not seeing anything unusual for your account in the service. You can try getting diagnostic logs to see if there are more details available on what is causing your program to fail. https://www.pulumi.com/docs/support/troubleshooting/#verbose-logging
i

icy-doctor-13719

01/06/2023, 6:41 AM
strange one:
error: template '2' not found
thanks - somehow running
dotnet clean
in the directory fixed the issue. no idea how that happened
w

white-balloon-205

01/06/2023, 6:53 AM
Glad to hear it is fixed now. Certainly we would expect to present a better error message here. If you have any additional information about what was wrong in the environment that led to this - we'd love to look deeper into why the error wasn't bubbled up to you more cleanly.