Hi, I am running integration tests and my test has...
# general
Hi, I am running integration tests and my test has taken longer than 10min which I think is the timeout. With that it used a random passphrase secret to run the tests. 1. how does the integration test code generate the PULUMI_CONFIG_PASSPHRASE 2. how do I up the timeout from 10min on the testing.
you can set a custom timeout on the resource itself. I’m not super familiart with the integration testing code
Pulumi up works fine (no timeouts) just timeouts exactly at 600 secs in the test and then orphans the stack. Who would best understand this scenario?
Ok found the default passphrase used when testing here, https://github.com/pulumi/pulumi/blob/master/pkg/testing/integration/command.go#L42
Now just need to figure out hte timeout bits.
we run integration tests in providers for way longer than 10mins and don’t have to configure anything: https://github.com/pulumi/pulumi-eks/blob/master/examples/cluster-go/main.go What resources are you creating in your test?
native EKS cluster and managed node groups.
I'll debug a bit, just seemed like such a round number that it had to be a setting.
Ah Pilot error, go test has the default timeout. just need to set it while running the test.