https://pulumi.com logo
#general
Title
# general
b

better-activity-84090

01/10/2023, 2:32 PM
Hello guys, has there been any network changes since yesterday on app.pulumi.com side ? Access to the console has become really slow (a couple of minute to load the page, same struggle when doing
pulumi up
from the cli) for several team members, using various french ISPs. It works fine while on a mobile hostpot, which points to a network/routing issue ?
e

eager-thailand-33661

01/10/2023, 3:28 PM
we are also experiencing the same kind of issues doing pulumi up from local dev environment, while running pulumi via github actions works just fine. We have tried different versions of pulumi but the same result. Pulumi commands take forever and the site is super slow. We are based in Sweden.
b

billowy-army-68599

01/10/2023, 3:50 PM
There haven’t been any changes to the website, we deploy in us-west-2 in AWS, so if there are issues from a network/routing perspective it’s likely well out of our control. Having said that, I have relayed this to the service team so they can investigate
would anyone be able to provide an MTR to app.pulumi.com ?
m

many-telephone-49025

01/10/2023, 3:52 PM
Hi @better-activity-84090 and @eager-thailand-33661, thanks for reporting. 🙌 The engineering team is also taking a look into this right now!
e

eager-thailand-33661

01/10/2023, 4:07 PM
the response time is different for different stacks, some load (but slower than usual) while others (with more resources) takes forever. The github action however seems to work at the usual response time.
b

billowy-army-68599

01/10/2023, 4:14 PM
Could you run a performance trace against an affected stack? https://www.pulumi.com/docs/support/troubleshooting/#performance
b

better-activity-84090

01/10/2023, 4:20 PM
This doesn’t seem to be related to stacks on my end, I can’t even load app.pulumi.com in a private browsing session (ie: not logged in) I’ve sent you mtr reports @billowy-army-68599
m

melodic-cat-62178

01/10/2023, 5:44 PM
Hey folks wanted to check in and see if the issues you've experienced are still happening for you?
b

better-activity-84090

01/10/2023, 5:48 PM
Looks way better on my side, thanks Steve
m

melodic-cat-62178

01/10/2023, 6:12 PM
Thanks for confirming @better-activity-84090! 😃
e

eager-thailand-33661

01/10/2023, 8:11 PM
now it works as expected, both the webapp and pulumi cli. Thanks! May I ask what was the issue?
b

billowy-army-68599

01/10/2023, 9:21 PM
@eager-thailand-33661 we’re actually working with AWS to try and determine that. We don’t see any performance issue or degradation on the service itself and in your
mtr
I see packet loss at the AWS layer. I’d be interested to see a new
mtr
to validate my hypothesis, but I think this may have been a global routing issue from Europe to AWS west
e

enough-painter-7423

02/02/2023, 1:44 PM
app.pulumi.com painfully slow for me, it took 11 secs to load
favicon.ico
in the incognito mode, 30 secs to load
loading-state.gif
. I'm in Singapore. I can also see every F5 results in an actual file downloading, perhaps due to lack of
If-None-Match
I'm sure I didn't forcibly disable caching on my Firefox, in fact a couple of files outside
<http://app.pulumi.com|app.pulumi.com>
returned 304, such as https://buttons.github.io/buttons.js
m

melodic-cat-62178

02/02/2023, 3:15 PM
Hey @enough-painter-7423 sorry to hear that it's so slow for you. Can I ask where geographically you are located? Last time this issue came up it was a networking issue from the europe region that caused the issue, but helpful to track down.
e

enough-painter-7423

02/02/2023, 4:55 PM
I’m in Singapore as previously mentioned
Maybe you can try ProtonVPN’s Tokyo server with their free plan