Hey everyone, I have a weird issue & wondering...
# general
Hey everyone, I have a weird issue & wondering if anyone has come across the same • I have an elasticache redis instance, created via pulumi • Recently upgraded the instance size type via pulumi, and that went fine • At some point I enabled logs on the elastiCache instance, but via AWS GUI not Pulumi • But this caused our pulumi deployments to fail , so I disabled the logs via AWS GUI • After all this, when I try to deploy to pulumi it still fails because of this log issue, error: ◦ Error updating ElastiCache cluster (prod-main), error: InvalidParameterValue: To modify the log delivery configuration, set the apply-immediately parameter to *. ◦ Note my pulumi config has "logDeliveryConfigurations": [] so not clear why the error is happening if logs disabled • But oddly enough, if I retry this same deployment the 2nd time (shortly after the failed deployment), it works and does not generate this error ◦ Issue still remains though -- by tomorrow if I run a new deployment, it will fail due to above error, I'll use my workaround of just rerunning the deployment and it works. But this initial failure I cannot seem to figure out - anyone ran into this issue before ?
Have you tried
pulumi refresh
recently? If the problem is caused by Pulumi not knowing the state in your provider, then refreshing will fix it.
Have not, I will give that a try Just weird that my pulumi config never changed, so it still shows elastiCache.logDeliveryConfigurations": [] and now that logs are disabled from AWS ElastiCache GUI expecting to be in sync but something must be off thanks though , I'll see if this helps