https://pulumi.com logo
Title
i

incalculable-thailand-44404

03/28/2023, 8:47 PM
Hi Folks, we recently started facing the issue mentioned here: https://github.com/pulumi/pulumi-eks/issues/720. I have added details about the error and our dependencies: https://github.com/pulumi/pulumi-eks/issues/720#issuecomment-1486265287. It would be great if anyone can guide me on this.
c

creamy-agency-52831

03/28/2023, 8:53 PM
It looks like the version of
pulumi-eks
you're using is fairly old - have you tried updating to
>=v1.0.0
?
i

incalculable-thailand-44404

03/28/2023, 8:58 PM
I tried, it yesterday. Let me try again. Will update in a bit
same error. my
package-lock.json
shows the updated eks packageā€¦
not sure why its not picking up the
aws-k8s-cni.yaml
that is available in the 1.0.0 version here:
<https://registry.npmjs.org/@pulumi/eks/-/eks-1.0.1.tgz>
Do I need to update other libs? @creamy-agency-52831 . Also, I really appreciate your help on this.
c

creamy-agency-52831

03/28/2023, 10:15 PM
If there are existing resources, they are likely registered with the specific version of the provider used to create them - let me check to see what our options are here šŸ™‚
q

quiet-jackal-96812

03/28/2023, 10:45 PM
Hey @incalculable-thailand-44404! Just did a quick look and it looks like the issue you're facing is slightly different than the one reported in https://github.com/pulumi/pulumi-eks/issues/720. Would you be able to create a new GH Issue from your comment so we can dig deeper into this and track our investigations? Thanks!
i

incalculable-thailand-44404

03/28/2023, 10:47 PM
Thanks a lot @quiet-jackal-96812. will do!
BTW, hwere are my dependencies for quick look (`package.json)`:
{
  "name": "cache-pulumi",
  "devDependencies": {
    "@types/node": "^14",
    "@typescript-eslint/eslint-plugin": "^5.13.0",
    "@typescript-eslint/parser": "^5.13.0",
    "eslint": "^8.10.0",
    "eslint-config-prettier": "^8.4.0",
    "eslint-plugin-prettier": "^4.0.0",
    "husky": "^7.0.4",
    "lint-staged": "^12.4.0",
    "prettier": "^2.5.1",
    "typescript": "^4.5.5"
  },
  "dependencies": {
    "@pulumi/aws": "^5.6.0",
    "@pulumi/awsx": "^0.40.0",
    "@pulumi/eks": "^1.0.0",
    "@pulumi/kubernetes": "^3.21.0",
    "@pulumi/pulumi": "^3.34.0"
  },
  "lint-staged": {
    "*.ts": "eslint --cache --cache-location ./node_modules/.cache/.eslintcache --fix"
  },
  "scripts": {
    "prepare": "husky install"
  }
}
@quiet-jackal-96812, just wanted to check if these look OK.
q

quiet-jackal-96812

03/28/2023, 11:27 PM
@incalculable-thailand-44404 These looks fine! Thanks for checking. Also, for sanity checking, did you try removing your
node_modules
folder and reinstalling your dependencies to see if the error persists?
i

incalculable-thailand-44404

03/28/2023, 11:53 PM
yes, I did. Created the ticket : https://github.com/pulumi/pulumi-eks/issues/870 @quiet-jackal-96812
BTW, I set the version of K8 to 1.21 explicitly and it worked!