Hello, We use Pulumi to manage our AWS resources. ...
# getting-started
Hello, We use Pulumi to manage our AWS resources. I have been having an issue where every time I run
pulumi preview
, I see uncommitted changes to my recently created objects (usually S3 Buckets with the change
diff: -serverSideEncryptionConfiguration
). When I run
pulumi up
and then preview again, I still see the same uncommitted changes. I do not see any material difference in the S3 buckets themselves in the AWS UI or otherwise. Does anyone know what is causing Pulumi to perceive the configuration for these resources to be different? I could not find any similar examples in these channels. Thanks!
This is this issue which is fixed in pulumi-aws 5.31.0. Could you try upgrading?
Thanks Thomas. When I run
pulumi version
, it says I am on v3.65.1
Do I need to run
brew update && brew upgrade pulumi
or is there a different action to take?
Hi James, the version of the Pulumi plugins is independent of the Pulumi version. You would upgrade the dependency on pulumi-aws in your program. The specifics depend on the programming language. In nodejs, e.g., you’d update
I see it, thanks again!