https://pulumi.com logo
#azure
Title
# azure
v

victorious-exabyte-70545

06/12/2023, 10:54 PM
Hi all, I am getting this error with an import:
Copy code
$ pulumi import azure-native:machinelearningservices:Datastore 'workspace-datastore'    '/subscriptions/....'
Previewing import (dev):
     Type                                               Name                 Plan       Info
     pulumi:pulumi:Stack                                machinelearning-dev             1 error
 =   └─ azure-native:machinelearningservices:Datastore  workspace-datastore  import     1 error


Diagnostics:
  azure-native:machinelearningservices:Datastore (workspace-datastore):
    error: Preview failed: autorest/azure: Service returned an error. Status=400 Code="MissingApiVersionParameter" Message="The api-version query parameter (?api-version=) is required for all requests."
When I do similar imports (azure-nativemachinelearningservicesCodeVersion for example), I do not get the error. Seems like the issue is with azure-nativemachinelearningservicesDatastore