https://pulumi.com logo
#getting-started
Title
# getting-started
w

witty-electrician-14202

06/28/2023, 10:47 PM
Hello! I'm new to Pulumi. I'm trying to deploy a bucket with minimal configuration:
Copy code
const bucketName = '...'

const bucket = new aws.s3.Bucket(bucketName, {
  bucket: bucketName,
})

module.exports = { bucket }
I logged in using an s3 bucket and if I run
pulumi up
it returns the following error:
Copy code
configuring Terraform AWS Provider: validating provider credentials: retrieving caller identity from STS: operation error STS: GetCallerIdentity, https response error StatusCode: 0, RequestID: , request send failed, Post "<https://sts.us-east-2.amazonaws.com/>": dial tcp: lookup <http://sts.us-east-2.amazonaws.com|sts.us-east-2.amazonaws.com> on [fe80::96ea:eaff:fe2b:ec16%en0]:53: no such host
Do you guys have any clue on how I fix this issue or even how I could debug it better? I've already checked and I was able to run the
aws sts get-caller-identity
normally on the AWS CLI. It seems very similar to this bug, but I can't move my state files from the s3 bucket
b

billowy-army-68599

06/28/2023, 11:47 PM
This is telling you your DNS lookups are failing. It’s a local error. Are you running from an ec2 instance?
w

witty-electrician-14202

06/28/2023, 11:48 PM
no, I'm running directly from my pc
b

billowy-army-68599

06/28/2023, 11:49 PM
Okay, we’ll you’re querying an ipv6 dns server and it’s failing. It’s likely not a Pulumi specific problem
w

witty-electrician-14202

06/28/2023, 11:50 PM
is there something I could do it to debug it?
b

billowy-army-68599

06/28/2023, 11:50 PM
Do a dns lookup for the sts address in the error
w

witty-electrician-14202

06/28/2023, 11:52 PM
Copy code
Server:		fe80::96ea:eaff:fe2b:ec16%11
Address:	fe80::96ea:eaff:fe2b:ec16%11#53

Non-authoritative answer:
Name:	<http://sts.us-east-2.amazonaws.com|sts.us-east-2.amazonaws.com>
Address: 52.95.18.19
does it mean something? (I'm lost here 🫠 )
well, it seems nothing is blocking the DNS lookup
b

billowy-army-68599

06/29/2023, 12:48 AM
it’s honestly hard to say, there’s a lot of potential issues, but I will say it’s a local configuration issue. You need to: • make sure you have valid AWS credentials both in your provider config and in your env vars • make sure you can make AWS API calls via the AWS CLI and AWS Go SDK
w

witty-electrician-14202

06/29/2023, 12:50 AM
in my company we use temporaries AWS credentials, so we normally setup with envs. is it necessary to have those credentials in the provider config?
I have no Go experience. May I test the JS SDK?
b

billowy-army-68599

06/29/2023, 12:53 AM
The library which stores your state in an s3 bucket uses the Go SDK
w

witty-electrician-14202

06/29/2023, 12:54 AM
the
pulumi init stack
command works and creates the state file
does it use the Go SDK?
Go it's pretty easy to setup. I manage to put together an example to list my S3 buckets and it's working as expected:
do you have any other tip to help me? I've tried everything I found on the internet, but it's still not working
b

billowy-army-68599

06/29/2023, 2:00 PM
can you share your stack configuration?
w

witty-electrician-14202

06/29/2023, 2:55 PM
Copy code
name: remix-poc
description: Remix app infrastructure
runtime: nodejs
Copy code
config:
  aws:region: us-east-2
I've tried the
skipCredentialsValidation
config, which makes the stack to start executing, at least. But one of my resources uses the
aws.getCallerIdentity()
, causing the error anyway
today a friend of mine ran the code in his environment and it worked. definitely it's something in my local configuration, but I don't even know where to lookup to
b

billowy-army-68599

06/29/2023, 10:46 PM
maybe try disabling ipv6 on your machine
w

witty-electrician-14202

06/30/2023, 11:11 AM
unfortunately, it did not work
@billowy-army-68599 thanks for the tips. I did not solve yet, but I found that connected in other network the error does not occur.
it's probably something in my router. I have no idea how to solve it
2 Views