https://pulumi.com logo
p

proud-noon-87466

06/28/2023, 11:02 PM
I'm getting issues installing cert-manager and datadog with helm release. They fail on the first try but succeed on subsequent tries. I get this error. I set the timeout 600 seconds in the Helm Release arguments but that didn't work.
Copy code
kubernetes:<http://helm.sh/v3:Release|helm.sh/v3:Release> (datadog-agent):
    warning: Helm release "datadog-agent" was created but has a failed status. Use the `helm` command to investigate the error, correct it, then retry. Reason: 2 errors occurred:
    	* the server could not find the requested resource
    	* the server could not find the requested resource
    error: 1 error occurred:
    	* Helm release "datadog/datadog-agent" was created, but failed to initialize completely. Use Helm CLI to investigate.: failed to become available within allocated timeout. Error: Helm Release datadog/datadog-agent: 2 errors occurred:
    	* the server could not find the requested resource
    	* the server could not find the requested resource

  kubernetes:<http://helm.sh/v3:Release|helm.sh/v3:Release> (cert-manager):
    warning: Helm release "cert-manager" was created but has a failed status. Use the `helm` command to investigate the error, correct it, then retry. Reason: 1 error occurred:
    	* the server could not find the requested resource
    error: 1 error occurred:
    	* Helm release "cert-manager/cert-manager" was created, but failed to initialize completely. Use Helm CLI to investigate.: failed to become available within allocated timeout. Error: Helm Release cert-manager/cert-manager: 1 error occurred:
    	* the server could not find the requested resource
v

victorious-church-57397

06/29/2023, 11:02 AM
Have you tried passing
customTimeouts
through to the helm release resource via the component resource arguments?
here's a code snippet from something that we do:
Copy code
const chart = new k8s.helm.v3.Release(
      `opentelemetry-operator`,
      {
        name: 'opentelemetry-operator',
        chart: 'opentelemetry-operator',
        namespace: namespace.metadata.name,
        createNamespace: false,
        version: '0.27.0',
        values: {
          admissionWebhooks: {
            certManager: {
              enabled: false,
            },
          },
        },
        repositoryOpts: {
          repo: '<https://open-telemetry.github.io/opentelemetry-helm-charts>',
        },
      },
      {
        provider,
        customTimeouts: { create: '2m' },
      }
    );
that will set the timeout in the pulumi program rather than at the chart level, hopefully that helps 🙂
p

proud-noon-87466

06/29/2023, 9:28 PM
Yes that seemed to work, thanks!
2 Views