https://pulumi.com logo
#aws
Title
# aws
b

billowy-vase-13469

08/25/2023, 10:41 AM
Hi, I have a task definition created with awsx.ecs.FargateTaskDefinition and I would like to change the default execution role to one that I've created. I've added the executionRole property and pointed it to my newly created role, as it was not set before:
Copy code
executionRole: {
  roleArn: updaterExecutionRole.arn,
}
Deploying it fails with the following error:
Error: failed to register new resource Pricing-UpdaterTaskDef [awsx:ecs:FargateTaskDefinition]: 2 UNKNOWN: Can't define role args if specified an existing role ARN
. The only other property I have on the task definition is the container, so I'm not specifying any role args. I tried settings
skip: true
in the executionRole properties, and when in combination with roleArn it still fails with the same error. If I delete roleArn and just set skip:true I can deploy, but then I'm missing the role. So redeploying it would be a solution, but I'd like the CI process to handle it in one-go to avoid down time. Do you have any solutions to this? Should I raise an issue on GitHub?
b

billowy-army-68599

08/25/2023, 1:47 PM
yep, please raise a github issue, looks like a bug
b

billowy-vase-13469

08/29/2023, 9:07 PM
I managed to get over the issue by just updating both pulumi/pulumi and pulumi/awsx to their latest version.