https://pulumi.com logo
#aws
Title
# aws
a

adamant-father-26302

10/26/2023, 9:31 AM
Copy code
❯ go get <http://github.com/pulumi/pulumi-awsx/sdk@v2.0.3|github.com/pulumi/pulumi-awsx/sdk@v2.0.3>
go: module <http://github.com/pulumi/pulumi-awsx@v2.0.3|github.com/pulumi/pulumi-awsx@v2.0.3> found (v2.0.3+incompatible), but does not contain package <http://github.com/pulumi/pulumi-awsx/sdk|github.com/pulumi/pulumi-awsx/sdk>
I get this error when trying to upgrade awsx from v1.0.2, ive read you should use major version in path, but pulumi-awsx does not seem to use that
had to
go get <http://github.com/pulumi/pulumi-awsx/sdk/v2|github.com/pulumi/pulumi-awsx/sdk/v2>
instead
m

melodic-tomato-39005

10/26/2023, 11:54 AM
Yeah, that’s annoying but unfortunately built in to how Go modules work. The path change is required for new major versions.