https://pulumi.com logo
#getting-started
Title
# getting-started
w

wide-scientist-62031

12/06/2023, 3:42 PM
Is there any way to increase the default timout..??
s

sparse-gold-10561

12/06/2023, 3:44 PM
w

wide-scientist-62031

12/06/2023, 6:05 PM
Tried it but it is not working..
Copy code
class SQS_with_DLQ:
    def __init__(self, resource_name, visibility_timeout_seconds, kms_master_key_id=None, kms_data_key_reuse_period_seconds=None, receive_count=10, message_retention_seconds=1209600, sqs_managed_sse_enabled=True,opts=None):
        self.dead_letter_queue = aws.sqs.Queue(f"{resource_name}-dlq",
            name=f"{resource_name}-dlq",
            visibility_timeout_seconds=visibility_timeout_seconds,
            sqs_managed_sse_enabled=sqs_managed_sse_enabled,
            message_retention_seconds=message_retention_seconds,
            kms_master_key_id=kms_master_key_id, # pass AWS KMS key id to kms_master_key_id argument
            kms_data_key_reuse_period_seconds=kms_data_key_reuse_period_seconds,
            tags={
                "Name": f"{resource_name}",
                "Project": "SKL-IAC",
                "POC": "True"
            },
            opts=pulumi.ResourceOptions(
                    # CustomTimeouts can be configured for create, update, and delete operations
                    # For this scenario, we're only setting the 'create' timeout to 30 minutes
                    custom_timeouts=pulumi.CustomTimeouts(update='10m',create='30m')
                )
        )
s

sparse-gold-10561

12/06/2023, 6:08 PM
i'm using the following and it works
Copy code
opts=pulumi.ResourceOptions(
        custom_timeouts=pulumi.CustomTimeouts(create="2h", update="2h", delete="2h")
    ),
w

wide-scientist-62031

12/06/2023, 6:33 PM
Tried your snippet too....still same issue..
s

sparse-gold-10561

12/06/2023, 6:39 PM
maybe something with this still?