https://pulumi.com logo
#google-cloud
Title
# google-cloud
a

adamant-hydrogen-25820

12/29/2023, 5:48 PM
Hi all, I am trying to upgrade our pulumi_gcp pip package version from 6.62.0 to 7.4.0. I've run into issues which I've detailed in this GitHub issue here: https://github.com/pulumi/pulumi-gcp/issues/1488 Basically what I'm facing is that I am unable to upgrade my stack because pulumi is trying to do a replace on all of my GCP
pulumi_gcp.secretmanager.Secret
resources but: 1. it shouldn't do that because no changes have been made to them 2. when it tries to it fails because its trying to create the new secret while the other still exists which causes a conflict on the name I found somewhere the unnecessary update to my secret resources may be getting triggered due to the provider name getting changed with the package upgrade? any thoughts on how to resolve this?
2 Views