https://pulumi.com logo
#general
Title
# general
n

narrow-midnight-97904

01/11/2024, 2:53 PM
Hi, while running the azure pipeline with new pulumi version 3.101.0, When accessing the stack using an azure keyvault as secrets provider, this fails: error: constructing secrets manager of type "cloud": secrets (code=InvalidArgument): POST https://some-vault.vault.azure.net/keys/some-key/decrypt -------------------------------------------------------------------------------- RESPONSE 400: 400 Bad Request ERROR CODE: BadParameter -------------------------------------------------------------------------------- { "error": { "code": "BadParameter", "message": "The parameter is incorrect.\r\n" } }-------------------------------------------------------------------------------
Could you suggest what i have to do to fix the issue.
s

steep-pager-59220

01/11/2024, 3:08 PM
Hi, upgrading to Pulumi 3.101.1 should fix this issue
n

narrow-midnight-97904

01/11/2024, 3:12 PM
in azure pipeline task: Pulumi@1 it will automatically download the 3.101.0 version
s

steep-pager-59220

01/11/2024, 5:05 PM
Interesting, looking at the code for the azure pipeline task it should always download the latest version, which now is 3.101.1, that was released yesterday. Is that not what's happening in your case? Would you be willing to share the azure pipeline docs?
n

narrow-midnight-97904

01/11/2024, 5:16 PM
Thank you Thomas Gummerer.
s

steep-pager-59220

01/11/2024, 5:34 PM
np! Also I meant logs not docs in case you still have issues 🤦
2 Views