https://pulumi.com logo
#golang
Title
# golang
m

many-stone-40872

03/15/2024, 3:47 PM
Hello, I am a newbie in using Pulumi. I am trying to use module github.com/pulumi/pulumi-kubernetes/sdk/v4/go/kubernetes/operators and when I do
go get <http://github.com/pulumi/pulumi-kubernetes/sdk/v4/go/kubernetes/operators|github.com/pulumi/pulumi-kubernetes/sdk/v4/go/kubernetes/operators>
it is showing me below error
Copy code
go: module <http://github.com/pulumi/pulumi-kubernetes/sdk/v4@upgrade|github.com/pulumi/pulumi-kubernetes/sdk/v4@upgrade> found (v4.9.1), but does not contain package <http://github.com/pulumi/pulumi-kubernetes/sdk/v4/go/kubernetes/operators|github.com/pulumi/pulumi-kubernetes/sdk/v4/go/kubernetes/operators>
Any ideas on this error please?
l

late-chef-72896

03/18/2024, 6:33 AM
There seems to be no operator package. what happens when you run
$ go install <http://github.com/pulumi/pulumi-kubernetes/sdk/v4/go/kubernetes@latest|github.com/pulumi/pulumi-kubernetes/sdk/v4/go/kubernetes@latest>
m

many-stone-40872

03/18/2024, 9:37 AM
Thanks @late-chef-72896 if the run the command you gave it is gives me
package <http://github.com/pulumi/pulumi-kubernetes/sdk/v4/go/kubernetes|github.com/pulumi/pulumi-kubernetes/sdk/v4/go/kubernetes> is not a main package
Any thoughts please?