Hey, hope this is the correct channel :pray: I am ...
# general
Hey, hope this is the correct channel 🙏 I am trying to release a new major version of my pulumi provider https://github.com/port-labs/pulumi-port and experiencing issues executing the upgrade-provider package. At first I tried to run the exposed gh action, but experienced issues as the package requires passing
param when upgrading to major, while the action doesn’t exposes all the supported parameters that the upgrade-provider package supports. Then I tried to upgrade it manually by passing the
param explicitly. And got the following -
Copy code
Major Version Updates are not fully automated!
You need to complete Step 11: Updating README.md and sdk/python/README.md in a follow up commit.
Steps are listed at
error: exit status 1:
go: finding module for package <http://github.com/port-labs/pulumi-port/sdk/v2/go/port/internal|github.com/port-labs/pulumi-port/sdk/v2/go/port/internal>
go: downloading <http://github.com/port-labs/pulumi-port|github.com/port-labs/pulumi-port> v1.11.1
go: <http://github.com/port-labs/pulumi-port/sdk/go/port|github.com/port-labs/pulumi-port/sdk/go/port> imports
        <http://github.com/port-labs/pulumi-port/sdk/v2/go/port/internal|github.com/port-labs/pulumi-port/sdk/v2/go/port/internal>: module <http://github.com/port-labs/pulumi-port@latest|github.com/port-labs/pulumi-port@latest> found (v1.11.1), but does not contain package <http://github.com/port-labs/pulumi-port/sdk/v2/go/port/internal|github.com/port-labs/pulumi-port/sdk/v2/go/port/internal>
and the link describing the steps is not available - https://github.com/pulumi/platform-providers-team/blob/main/playbooks/tf-provider-major-version-update.md So I’m quite stuck atm, and would really appreciate some help