https://pulumi.com logo
#general
Title
# general
c

cuddly-magician-97620

07/27/2022, 2:07 PM
Hi All, Setting up Reshift Cluster like this:
Copy code
const redshiftCluster = new aws.redshift.Cluster(`redshift-cluster-${stack}`, {
    clusterSubnetGroupName: redshiftSubnetGroup.id,
    clusterIdentifier: `redshift-cluster-${stack}`,
    clusterType: "multi-node",
    numberOfNodes: Number(redshiftConfig.require("number-of-nodes")),
    encrypted: true,
    logging: {
        enable: true,
    },
    publiclyAccessible: false,
    enhancedVpcRouting: true,
    databaseName: redshiftConfig.require("database-name"),
    masterPassword: redshiftConfig.require("master-password"),
    masterUsername: redshiftConfig.require("master-username"),
    nodeType: redshiftConfig.require("node-type"),
    skipFinalSnapshot: true,
    tags: {
        Pulumi: "True",
        env: stack,
    },
});
the
logging
block is giving me a hard time. AWS recommends Cloudwatch, and Pulumi docs say I should be able to use it. But Pulumi does not like this:
Copy code
logging: {
        enable: true,
        logDestinationType: "cloudwatch",
    },
Pulumi v3.34.1 pulumi/aws 4.29.0 What am I doing wrong? Could it be that my aws provider is too old?