Hello all, I am new to Pulumi and we are planning ...
# getting-started
Hello all, I am new to Pulumi and we are planning to migrate our application from a private cloud to Microsoft Azure. So far we have always worked with Azure CLI or directly in Azure Portal for the purpose of validation and proof of concept. We would like to deploy the resources using Pulumi and therefore I have started installing Pulumi and going through the Getting Started section of the doc (Azure, TypeScript). The problem I am having occurs in the context of
pulumi up
. When I run the command, more or less nothing is done. That means the processing time is about 10secs and the only thing I get is a headline
Previewing update (appservice-test):
without any content and afterwards a further headline
also without any content. A screenshot of the terminal window in VSCode is attached... The behavior accours which each pulumi example code which I tested. A call to
pulumi up --logtostderr -v=9 --debug 2> out.txt
shows the following error text in out.txt: I0801 103655.680367 14836 host.go:486] Error closing 'nodejs' language plugin during shutdown; ignoring: 1 error occurred: TerminateProcess: Access is denied. (see attachment for full ou.txt file) A colleague of mine who works at another site has the identical error behavior. I hope someone of aou can help use - thanks in advance for your support!
Hello @few-lizard-48557 , could you run
pulumi about
for me and paste the results?
Copy code
PS C:\workspace\azure-ts-appservice> pulumi about
Version      3.37.2
Go Version   go1.17.12
Go Compiler  gc

azure-native  1.67.0
nodejs        unknown

OS       Microsoft Windows 10 Enterprise
Version  10.0.19044 Build 19044
Arch     x86_64

This project is written in nodejs: executable='C:\Program Files\nodejs\node.exe' version='v14.16.0'

Name           LO6-C-000CU
URL            file://~
User           DE\wolfsch6

Pulumi locates its logs in C:\Users\wolfsch6\AppData\Local\Temp by default
warning: Failed to get information about the Pulumi program's plugins: Found C:\workspace\azure-ts-appservice\package-lock.json but not npm: unable to find program: npm.exe      
warning: Failed to get information about the current stack: No current snapshot
PS C:\workspace\azure-ts-appservice>
This looks similar to this issue: https://github.com/pulumi/pulumi/issues/3590 Your
pulumi about
output mentions that it can’t find
. Does NodeJS start correctly when you run
node -v
Hi Ringo and thank you for your feedback. Nodejs runs at this machine proper with several Repos.
node -v
shows: V14.16.0
@few-lizard-48557 for
pulumi about
, any reason it can’t find
on your system?
and referring back to the linked ticket: do you have a proxy configured which might not correctly discard
Hi Ringo, I just checked the link you forwarded but I'm not sure whether I do fully understand the information which is posted. I have an authentification proxy (px.exe) installed. The configuration of this proxy (px.ini) is the following:
I can call it in the VSCode terminal (where I also run
pulumi up
) and there it works.
line is what I was after. Pulumi uses a network GRPC protocol to communicate between the language host, the engine and the provider binaries, all locally on your machine. If these network connections, albeit locally, are obstructed, then Pulumi doesn’t work correctly. In your case, the proxy is correctly configured as far as I can see, not to proxy for connections on your own machine
and internal private networks
I have now added "" and "localhost" to the `noproxy`configuration, restarted the console and tried
pulumi up
again => unfortunately without success... (That was just a helpless attempt from my side)
Do you have any other idea how we can force the system to tell us what exactly is going wrong behind the scenes?
Unfortunately not at the moment. This week, Pulumi is having a company wide refresh week. I can’t consult any of the core engineers this week unfortunately.
Hello Ringo, your tip with the proxy configuration was a hot tip for me and I would like to thank you expressly for it and I have also been able to find out in the meantime where exactly the dog is buried in the proxy configuration. So here is the resolution to the proxy configuration for my computer in the hope that it may still be useful for others... So the whole proxy configuration is apparently a 2-stage thing, i.e. on the one hand there are entries in the environment variables which are
and `HTTPS_PROXY:`which on my computer forward to the authentication proxy (Px.exe) which listens on port 3128. In addition, there is an further proxy entry
NO_PROXY: localhost,.<http://bosch.com|bosch.com>,.<http://bosch-iot-cloud.com|bosch-iot-cloud.com>
in the environment variables. In NO_PROXY the entry is missing on my system, which probably means that the requests for this ip are forwarded to the PX proxy. This is the case for the GRPC communication between the language host and the engine, but the PX proxy has configured an exclusion for and somehow the instances involved cannot handle this in a proper way... I have now added the exclusion "" to the environment variable
, which probably means that a request to this address will not be forwarded to the PX.exe proxy and everything now works as expected, i.e. by calling the command
Pulumi up
I get a preview of all Azure resources that are created during the call. Many thanks again for the fast and good support!
🎉 1
Glad I could help you out! Have fun with Pulumi.
This one was worth mentioning on our Troubleshooting page. https://github.com/pulumi/pulumi-hugo/pull/1797