https://pulumi.com logo
#pulumiverse
Title
# pulumiverse
b

big-architect-71258

08/30/2022, 1:04 PM
@limited-rainbow-51650 The Time provider still doesn't show up in the Pulumi Registry. Is there something missing. Checked the registry pipeline already:
l

limited-rainbow-51650

08/30/2022, 1:23 PM
It only requires this to be merged: https://github.com/pulumi/registry/pull/1419
👍🏼 1
b

big-architect-71258

08/30/2022, 1:27 PM
Ah okay. I already suspected that it had to do with the shortened name.
l

limited-rainbow-51650

08/30/2022, 1:29 PM
No, you can take that along in a next release.
b

big-architect-71258

08/30/2022, 1:31 PM
I remember a new v-Tag will trigger the Registry Bot and include the shortened name what will (hopefully) publish the Provider to the registry. Right?
l

limited-rainbow-51650

08/30/2022, 1:33 PM
The PR I mentioned will publish the provider in the registry as
Pulumi Time Provider
(the “old” name). If you create a new tag, the daily cron job in the registry will detect the new release and create a new PR in the registry repo to publish the new tag into the registry.
👍🏼 1
b

big-architect-71258

08/30/2022, 2:08 PM
Created a new Tag v0.0.8 and this time with
--no-sign
at the end of the command like you did. Tag is still `verified`on GitHub.
@limited-rainbow-51650 So the time provider isn't (correctly?) published to the Registry. I can't install the provider locally using:
pulumi plugin install resource time
error: 404 HTTP error fetching plugin from <https://api.github.com/repos/pulumi/pulumi-time/releases/latest>. If this is a private GitHub repository, try providing a token via the GITHUB_TOKEN environment variable. See: <https://github.com/settings/tokens>
Is there a REST endpoint to query the registry?
l

limited-rainbow-51650

08/31/2022, 3:22 PM
b

big-architect-71258

08/31/2022, 3:33 PM
Using Pulumi version 3.38.0, because I know that the special
github://
download URLs are only supported after 3.35.3
When I compare the definition in the
astra
provider, the only difference is that the
astra
provider omits the repository from the download URL:
<github://api.github.com/pulumiverse>
. The spec states that it's perfectly valid to add the provider repository as well:
github://${github api host}/{organization}[/{repository}]
.
BTW
pulumi plugin install resource astra
shows the same
404
error.
Same issue with
pulumi plugin install resource upstash
This works!
pulumi plugin install resource time --server <github://api.github.com/pulumiverse/pulumi-time>
I suspect that the
pulumi
CLI uses the "default" (standard?) download path
<https://api.github.com/repos/pulumi/pulumi-time/releases/latest>
instead of querying the registry for the download URL of the provider, if no
--server
argument is passed.
l

limited-rainbow-51650

08/31/2022, 3:54 PM
If you use the NodeJS SDK, the server URL is in the
package.json
, so the install script should correctly know where to download the plugin binary from: https://github.com/pulumiverse/pulumi-time/blob/main/sdk/nodejs/package.json#L28
b

big-architect-71258

08/31/2022, 3:55 PM
Well when using YAML you completely rely on pulumi CLI doing it's job correctly.
And of course, as with terraform, I'd expect that
pulumi plugin install
looks up the correct download url.
I suspect that you can't use any of the community providers out of the box with YAML. Right?
Well, after installing the time provider manually, it's working perfectly using a YAML configuration.
Copy code
name: Time
runtime: yaml
description: A YAML sample to show the usage of the Pulumi Time provider

configuration: {}
variables:     {}
resources:
  rotation:
    type: time:Rotating
    properties:
      rotationMinutes: 1
outputs:       {}
l

limited-rainbow-51650

08/31/2022, 5:15 PM
Support for setting the
pluginDownloadURL
in a Pulumi YAML project is merged into the code base 3 weeks ago: https://github.com/pulumi/pulumi-yaml/pull/296 I’m trying to track down if it is already in a release. It is definitely not documented yet here: https://www.pulumi.com/docs/reference/yaml/
👍🏼 1
4 Views