<@UK4HNFLCB> The Time provider still doesn't show ...
# pulumiverse
@limited-rainbow-51650 The Time provider still doesn't show up in the Pulumi Registry. Is there something missing. Checked the registry pipeline already:
It only requires this to be merged: https://github.com/pulumi/registry/pull/1419
👍🏼 1
Ah okay. I already suspected that it had to do with the shortened name.
No, you can take that along in a next release.
I remember a new v-Tag will trigger the Registry Bot and include the shortened name what will (hopefully) publish the Provider to the registry. Right?
The PR I mentioned will publish the provider in the registry as
Pulumi Time Provider
(the “old” name). If you create a new tag, the daily cron job in the registry will detect the new release and create a new PR in the registry repo to publish the new tag into the registry.
👍🏼 1
Created a new Tag v0.0.8 and this time with
at the end of the command like you did. Tag is still `verified`on GitHub.
@limited-rainbow-51650 So the time provider isn't (correctly?) published to the Registry. I can't install the provider locally using:
pulumi plugin install resource time
error: 404 HTTP error fetching plugin from <https://api.github.com/repos/pulumi/pulumi-time/releases/latest>. If this is a private GitHub repository, try providing a token via the GITHUB_TOKEN environment variable. See: <https://github.com/settings/tokens>
Is there a REST endpoint to query the registry?
Using Pulumi version 3.38.0, because I know that the special
download URLs are only supported after 3.35.3
When I compare the definition in the
provider, the only difference is that the
provider omits the repository from the download URL:
. The spec states that it's perfectly valid to add the provider repository as well:
github://${github api host}/{organization}[/{repository}]
pulumi plugin install resource astra
shows the same
Same issue with
pulumi plugin install resource upstash
This works!
pulumi plugin install resource time --server <github://api.github.com/pulumiverse/pulumi-time>
I suspect that the
CLI uses the "default" (standard?) download path
instead of querying the registry for the download URL of the provider, if no
argument is passed.
If you use the NodeJS SDK, the server URL is in the
, so the install script should correctly know where to download the plugin binary from: https://github.com/pulumiverse/pulumi-time/blob/main/sdk/nodejs/package.json#L28
Well when using YAML you completely rely on pulumi CLI doing it's job correctly.
And of course, as with terraform, I'd expect that
pulumi plugin install
looks up the correct download url.
I suspect that you can't use any of the community providers out of the box with YAML. Right?
Well, after installing the time provider manually, it's working perfectly using a YAML configuration.
Copy code
name: Time
runtime: yaml
description: A YAML sample to show the usage of the Pulumi Time provider

configuration: {}
variables:     {}
    type: time:Rotating
      rotationMinutes: 1
outputs:       {}
Support for setting the
in a Pulumi YAML project is merged into the code base 3 weeks ago: https://github.com/pulumi/pulumi-yaml/pull/296 I’m trying to track down if it is already in a release. It is definitely not documented yet here: https://www.pulumi.com/docs/reference/yaml/
👍🏼 1