Thread
#getting-started
    b

    better-agent-38563

    2 weeks ago
    How can I install the Pulumi executable to be accessible for all users on Windows Server? Trying to get things running in CI and that's a roadblock.
    l

    limited-rainbow-51650

    2 weeks ago
    Hello @better-agent-38563, if you use the MSI installer, isn’t that a system-wide installation?https://www.pulumi.com/docs/get-started/install/
    b

    better-agent-38563

    2 weeks ago
    Apparently not, since that's what I tried. I'll do some searching to see where the files went. Maybe it's just a path problem for the CI user?
    l

    limited-rainbow-51650

    2 weeks ago
    If your account doesn’t have
    Administrator
    rights, it might be worth a try to run the installer using the
    Run as
    option and fill in the user details of the Administrator account.https://docs.microsoft.com/en-us/troubleshoot/windows-server/shell-experience/use-run-as-start-app-admin
    b

    better-agent-38563

    2 weeks ago
    MSI installed it in "Program Files(x86)" and when I explicitly set the path to it when I run it, it works, so I suspect it's just the path for the CI user that has not been updated yet. I think I'm okay for now. Thanks for the input.