c

    crooked-river-11449

    5 days ago
    Hello my name is Sacha from Cape Town South Africa and I am really enjoying using Pulumi. Its a brilliant tool! Whenever I run
    pulumi up
    I get
    could not validate provider configuration
    invalid or unknown key
    . I am using Pulumi version 3.39 and I am deploying a YAML project to my
    localstack
    on AWS. Any advice would be much appreciated thank you.
    l

    limited-rainbow-51650

    5 days ago
    This might be something
    localstack
    related. Have you compared your setup with the Localstack docs here?https://docs.localstack.cloud/integrations/pulumi/ The localstack people have a wrapper script which sets some of these items correct:https://github.com/localstack/pulumi-local
    c

    crooked-river-11449

    5 days ago
    Thank you Ringo for the reply I will try the wrapper.